编译安装 MPlayer SVN-r29832-snapshot-4.4.1 通过 

最近换上了UBUNTU 9.10,许多软件都要全新安装,mplayer也不例外.

下载mplayer最新的 snapshot版本,解压.

我的 configure:

configuration: --prefix=/usr/local/mplayer --enable-gui --enable-radio --enable-radio-capture --enable-wii --language-doc=zh_CN --language-man=zh_CN --language-msg=zh_CN --language=zh_CN

缺依赖就 apt-get.

值得注意的是:mplayer编译 --enable-gui 需要 gtk+ 库的支持.

下载gtk+最新版本 2.19.0的源码編译,需要依赖glib,pango,cairo,atk等
(一定要先cairo后pango,否则编译gtk+时会找不到cairo).
而在 built glib 的时候,又需要gettext.
当make gettext 的时候,如果和我一样,用的是GCC4.4.1 这样的较新的版本,会报一个传递参数数量不匹配的错,要注意修改.

附我安装gtk+组件的 configure:

It was created by gtk+ configure 2.19.0, which was
generated by GNU Autoconf 2.63. Invocation command line was

$ ./configure --prefix=/usr/local/gtk+

It was created by glib configure 2.22.2, which was
generated by GNU Autoconf 2.63. Invocation command line was

$ ./configure

It was created by pango configure 1.26.0, which was
generated by GNU Autoconf 2.63. Invocation command line was

$ ./configure

It was created by configure, which was
generated by GNU Autoconf 2.61. Invocation command line was

$ ./configure

当然,这一切都可以通过 apt-get 获得.

[ ] ( 2205 次浏览 ) 永久链接 ( 2.9 / 1814 )

<< <上一页 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 33 | 34 | 下一页> >>