编译 php 5.3.0 通过 

突然想要升级到php5.3.0版本,于是马上行动了

下载tar.gz包,解压

我的configure:

[[email protected] php-5.3.0]# ./configure --prefix=/usr/local/PHP --enable-mod-charset --enable-embed --with-apxs2=/usr/local/apache/bin/apxs --enable-sigchild --enable-libgcc --enable-fd-setsize=1024 --with-openssl --with-kerberos --with-zlib --with-bz2 --enable-calendar --with-curl --with-curlwrappers --enable-dba --enable-exif --enable-ftp --with-gd --enable-gd-native-ttf --with-imap --with-mhash --with-imap-ssl --enable-intl --enable-mbstring --with-icu-dir=/usr/local/ICU/ --with-ldap --with-mcrypt --with-mysql=/usr/local/mysql --with-mysqli --enable-embedded-mysqli --enable-soap --enable-sockets --enable-sysvmsg --enable-sysvsem --enable-sysvshm --enable-wddx --with-xmlrpc --enable-zip --enable-maintainer-zts

一开始加了一些自己都不清楚的组件,如litespeed,

./configure 可以通过,make也没问题,但是一旦make install 就挂了.遇到了一个大家公共的问题

chmod: failed to get attributes of `/usr/local/apache/modules/libphp5.so': No such file or directory apxs:
Error: Command failed with rc=65536 .
make: *** [install-sapi] Error 1


后来删掉了一些参数,便通过了.

还有如果要使用phpmyadmin 3.2.0后的新版本,一定要加上 mbstring,mcrypt 支持.
[ ] ( 2491 次浏览 ) 永久链接 ( 3 / 1464 )

<< <上一页 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 33 | 34 | 下一页> >>