成功编译 apache 2.2.12 

有人一定觉得奇怪,apache 现在的最高版本才是2.2.11,怎么我就编译了2.2.12呢 呵呵

其实这是dev版,不过很快就要正式了。

下面是我的./configure

[[email protected] usr]# ./configure --prefix=/usr/local/apache --enable-modules="all" --enable-charset-lite --enable-proxy --enable-ssl --enable-http --enable-dav --enable-info --enable-cgi --enable-cgid --enable-dav-fs --enable-dav-lock --enable-vhost-alias --enable-rewrite --enable-so --with-apr=/usr/local/apr --with-apr-util=/usr/local/apr-util

过程中基本没有什么难度,就是 apr(Apache Portable Runtime Util)让我郁闷了一下,不过安装一下就可以通过了.

本来是打算安装mod_dav-1.0.3-1.3.6.tar.gz的,不过无论是
./configure --with-apxs=/usr/local/apache/bin/apxs
还是
./configure --with-apache=/usr/local/apache
都报
the APXS installation may be broken
这个错.

让我去http://www.webdav.org/mod_dav/install.html找原因.
索性不装了,好在发现apache集成了这个,呵呵
[ 23 评论 ] ( 1136 次浏览 ) 永久链接 ( 3 / 1392 )

<< <上一页 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 下一页> >>