编译安装 VLC media player 1.0.6 Goldeneye 通过 

刚安装了ubuntu 10.04 系统,体验很好.

不过自带的totem 播放rmvb有黑屏现象,故想安装一个VLC。

下载vlc 最新版本 1.0.6,解压,进入目录.

我的configure:
It was created by vlc configure 1.0.6, which was
generated by GNU Autoconf 2.65. Invocation command line was

$ ./configure --prefix=/usr/local/vlc --bindir=/usr/local/bin --sbindir=/usr/local/sbin --sysconfdir=/etc/sysconfig --localstatedir=/var --enable-optimize-memory --enable-dvdread --enable-cddax --enable-vcdx --enable-wma-fixed --enable-real --enable-realrtsp --enable-flac --enable-snapshot --enable-cyberlink --disable-mtp --disable-live555 --disable-gme

我不得不说,vlc的依赖是最多的.

这是我报的错:
configure: WARNING: lua5.1 not found, trying lua >= 5.1 instead
configure: WARNING: lua >= 5.1 not found!
configure: WARNING: TagLib library not found
configure: WARNING: cannot find libdvbpsi headers
configure: WARNING: LibV4L2 support disabled because libv4l2 development headers were not found
configure: WARNING: CD Reading and information library not found
configure: WARNING: VCD information library not found
configure: WARNING: cddax plugin disabled because ok libcdio library not found or disabled
configure: WARNING: vcdx plugin disabled because ok libvcdinfo library not found or disabled
configure: WARNING: vcdx plugin disabled because ok libiso9660 library not found
configure: WARNING: vcdx plugin disabled because ok libvcdinfo library not found
configure: WARNING: the dvb access module requires libdvbpsi
configure: error: Could not find libmad on your system: you may get it from http://www.underbit.com/products/mad/. Alternatively you can use --disable-mad to disable the mad plugin.

按照我之前写过的一篇日志里面张贴的依赖清单,一个个 apt-get.
值得一提的是,libdvbpsi库的deb包,在网易的源里没有就绪.
至少我当时是这样的,可以从packages.ubuntu.com 搜索到.

再次检查,报 g++ no found 错.安装g++. make clean 一下.

再次检查依赖,make.

又报了个 make alias 权限不足.检查了下源码包,跟目录下有个make-alias.
chmod u+x make-alias.

再次make 通过.

之后sudo make install.安装成功.

输入vlc,成功运行.

如图:

[ ] ( 1195 次浏览 ) 永久链接 ( 3 / 1428 )

<< <上一页 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 33 | 下一页> >>