编译安装 Pidgin 2.7.0 通过 

昨天pidgin 发布了最新的2.7.0 版本,打算跟进了。
不过ubuntu官方的PPA源永远是滞后的,还是2.6.6 囧rz

也难怪了,只有一位开发者在维护。于是便自己动手了.

下载源码包,解压,进入目录.

我的configure:

sharl@sharl-laptop:~/pidgin-2.7.0$ ./configure \
> --prefix=/usr/local/pidgin \
> --bindir=/usr/local/bin \
> --sbindir=/usr/local/sbin \
> --sysconfdir=/etc/sysconfig \
> --localstatedir=/var \
> --disable-largefile \
> --disable-screensaver \
> --enable-cap \
> --enable-gnutls=no \
> --enable-nss=no \
> --with-extraversion=Sharl_IM \
> --with-x \
> --with-python

检查依赖,报了一个doxgen的警告
configure: WARNING: *** Doxygen not found, docs will not be available

直接忽略掉(因为我不需要帮助文档), make && make install.

一段时间后,安装完成.

运行 pidgin ,OK了
sharl@sharl-laptop:~/pidgin-2.7.0$ pidgin --version
Pidgin 2.7.0-Sharl_IM (libpurple 2.7.0)

重新配置帐号(因为之前的配置文件被我删掉了),便可以登录了
别忘了把QQ版本号调为2008,不然可是登不上的(默认2005).
[ 1 评论 ] ( 822 次浏览 ) 永久链接 ( 3 / 1293 )

<< <上一页 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 下一页> >>