编译安装 Pidgin 2.7.3 通过 

今天看到pidgin 官网放出了“Pidgin 2.7.3 is out and contains some important crash fixes” 字样,打算改用新的版本.

在ubuntu packages 里面查了下,pidgin 还是2.6.6 版本,pidgin 官方推荐的PPA(https://launchpad.net/~pidgin-developers/+archive/ppa/+files/pidgin-ppa_0.0.3_all.deb)目前也还只是2.7.1 版本,

故而只好自己动手了,下载最新源码包,解压,进入目录

我的configure:
[email protected]:~/下载/pidgin-2.7.3$ ./configure \
> --prefix=/usr/local/pidgin \
> --exec-prefix=/usr/local \
> --sysconfdir=/etc/sysconfig \
> --localstatedir=/var \
> --enable-static=no \
> --enable-shared=no \
> --disable-largefile \
> --disable-consoleui \
> --disable-screensaver \
> --disable-startup-notification \
> --disable-gstreamer \
> --disable-gstreamer-interfaces \
> --disable-farsight \
> --disable-vv \
> --disable-fortify \
> --enable-gnutls=no \
> --enable-nss=no \
> --enable-trayicon-compat \
> --disable-doxygen \
> --disable-dot \
> --disable-devhelp \
> --with-extraversion=SHARL_LINUX_IM \
> --with-x \
> --with-static-prpls=all \
> --with-python

检查依赖,一切顺利(因为本台机器已经不是第一次编译pidgin了).
紧接着 make && make install 编译 和 安装.

当然之前最好先删除之前老版本的pidgin(如果安装目录一样的话),不然configure 的时候就会有警告了.

编译时间可能会很长,等下即可安装完成.

运行 pidgin 即可,进行添加QQ帐号(如果用户配置文件 ~/.purple 被删的话),添加完成后即可进行聊天了.

切换到“可用”,提示:
您的号码可能存在异常情况,已受到限制登录保护,需激活后才能正常登录。激活网址: http://jihuo.qq.com


看来又要激活了,腾讯什么时候才能完美支持pidgin 呢?? 嚓~

[ ] ( 7152 次浏览 ) 永久链接 ( 3 / 1664 )

<< <上一页 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 下一页> >>