编译安装 PHP 5.3.3 通过 

最近php 5.3.x 分支发布了5.3.3版本.而我现在的vps还是在用5.3.3-dev版,存在不少已知的bug,看来是时候会升级了.

下载php 5.3.3 源码包,解压,进入目录

依然还是要以fastcgi形式跑php,所以必须把php-fpm编译进来。不过这次我不需要再去从SVN里面签出php-fpm了,因为从5.3.3正式版开始,php-fpm 已经被内置了.

下面是我的configure:
[root@PowerPC php-5.3.3]# ./configure \
> --prefix=/usr/local/php \
> --exec-prefix=/usr/local \
> --sysconfdir=/etc/sysconfig \
> --localstatedir=/var \
> --enable-fpm \ #启用php-fpm
> --with-fpm-user=http \
> --with-fpm-group=web \
> --with-config-file-path=/etc \
> --disable-ipv6 \
> --with-openssl \
> --with-pcre-regex \
> --with-zlib \
> --with-bz2 \
> --enable-calendar \
> --with-curl \
> --enable-dba=shared \
> --enable-exif \
> --enable-ftp \
> --with-gd \
> --enable-gd-native-ttf \
> --with-mhash \
> --with-imap \
> --with-kerberos \
> --with-imap-ssl \
> --enable-intl \
> --with-ldap \
> --enable-mbstring \
> --with-mcrypt \
> --with-mysql \
> --with-mysql-sock \
> --with-mysqli \
> --enable-soap \
> --enable-sockets \
> --enable-wddx \
> --with-xmlrpc \
> --with-xsl \
> --enable-zip \
> --with-pear \
> --enable-zend-multibyte

检查依赖,缺什么自己用yum search 一下,安装即可.

如果报 configure: warning: lemon versions supported for regeneration of libsqlite parsers: 1.0 (found: none) 这样的错的话,
可以通过以下方法解决:

wget http://www.sqlite.org/cvstrac/getfile/sqlite/tool/lemon.c
gcc -o lemon lemon.c
mv lemon /usr/local/bin/ 即可.

如果是rpm安装的mysql的话,可能还会找不到libmysqlclient.so 文件,复制到程序搜索的目录即可.

之后,make && make install.
时间会相当的长,要等一等.

完了之后,php 就安装好了.

运行php -v 查看版本:
PHP 5.3.3 (cli) (built: Jul 31 2010 11:37:19)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

再看一下php-fpm的信息:
[root@PowerPC php-5.3.3]# php-fpm -v
PHP 5.3.3 (fpm-fcgi) (built: Jul 31 2010 11:36:42)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies

看起来一切正常.

再复制源码包下的php.ini-development 文件至/etc 下,并改名为php.ini .
修改/etc/sysconfig/php-fpm.conf.default 文件,并改名为php-fpm.conf.

这下配置就算完成了.

重启cherokee,一切完成.

注:发现discuz! 7.2 在 php 5.3.3 下面挂了,phpwind 正常,wordpress 正常,phpmyadmin 正常……
[ 发表评论 ] ( 923 次浏览 ) 永久链接 ( 3 / 1304 )
编译安装 Cherokee Web Server 1.0.5b 通过 

这周cherokee 发布了1.0.5 版本,修复SSL/TLS 和 php-fpm 支持的一些bug,还有一些琐碎的修复.总之,值得更新.

今天下载了起源码包,打算更新至新版本.

解压,进入目录

我的configure:
[root@PowerPC cherokee-1.0.5]# ./configure \
> --prefix=/usr/local/cherokee \
> --enable-beta \
> --enable-os-string=Sora_Aoi \
> --enable-trace \
> --enable-backtraces \
> --disable-largefile \
> --disable-ipv6 \
> --enable-internal-pcre \
> --disable-pam \
> --enable-static-module=all \
> --without-libssl \
> --without-ldap \
> --without-mysql \
> --without-geoip \
> --without-ffmpeg \
> --with-wwwuser=http \
> --with-wwwgroup=web

检查依赖,通过 . make && make install 编译安装.

很快就完成了.

接下来用备份的cherokee.conf 覆盖下 PREFIX/etc/cherokee 下的同名文件.即可恢复配置.

再次在console 下 执行 cherokee -d 启动服务器即可.

升级完成.
[ 发表评论 ] ( 910 次浏览 ) 永久链接 ( 3 / 1251 )
编译安装 Subversion 1.6.12 通过 

最近打算用php 开发一个类似bt种子文件的分享站点,项目嘛准备托管到谷歌code上面去.

由于我是用netbeans开发的,所以之前eclipse里面用的svn 工具不能用了。因为nb 要求必须指定svn binary的路径.所以便打算安装一个svn.

可是看到ubuntu packages 里面居然还是 1.6.6 版本,而svn 已经到了 1.6.12……故而决定自己手动编译一个.

从官方站点下载源码和依赖包(注意svn 已经转投了apache foundation了),解压,进入目录

我的configure:

之前最好重新生成configure 文件.
sharl@sharl-laptop:~/下载/subversion-1.6.12$ ./autogen.sh

sharl@sharl-laptop:~/下载/subversion-1.6.12$ ./configure \
> --prefix=/usr/local/svn \
> --bindir=/usr/local/bin \
> --sbindir=/usr/local/sbin \
> --sysconfdir=/etc/sysconfig \
> --localstatedir=/var \
> --disable-mod-activation \
> --with-ssl \
> --with-jdk

由于我这个svn 只是作为客户端Client 来用的,所以关系到服务器端的功能(httpd server、svnserve)均被禁用掉了.

检查依赖,svn 几个必须的依赖(如 APR,APR-util,neon,serf等)全都放在*deps 的包里了。所以过程很顺利.

可能 sasl2 会缺依赖,sudo apt-get install libsasl2 即可.

之后,进行编译. make && make install .

过程会很漫长.完了之后.svn 就算安装成功了.

现在netbeans 已经可以找到svn 的可执行文件了.

查看svn 信息:
sharl@sharl-laptop:~/下载/subversion-1.6.12$ svn --version
svn,版本 1.6.12 (r955767)
编译于 Jul 4 2010,18:37:37

版权所有 (C) 2000-2009 CollabNet。
Subversion 是开放源代码软件,请参阅 http://subversion.tigris.org/ 站点。
此产品包含由 CollabNet(http://www.Collab.Net/) 开发的软件。
[ 2 评论 ] ( 1033 次浏览 ) 永久链接 ( 3 / 1233 )
编译安装 VLC media player 1.1.0 The Luggage 成功 

最近著名开源播放器VLC 发布了1.1.0 版本,支持GPU硬解,播放高清HD 能力增强.
再加上我用的1.0.6版本在播放《空姐全集》的时候,表现不是很好.有的时候会出现一些莫名其妙的错误,比如画面不出来,声音也挂了的情况。故而决定升级.

从VLC官方镜像下载1.1.0 源码包,解压,进入目录

我的configure:
sharl@sharl-laptop:~/vlc-1.1.0$ ./configure \
> --prefix=/usr/local/vlc \
> --bindir=/usr/local/bin \
> --sbindir=/usr/local/sbin \
> --sysconfdir=/etc/sysconfig \
> --localstatedir=/var \
> --enable-optimize-memory \
> --enable-vcdx \
> --disable-gme \
> --disable-libva \
> --enable-wma-fixed \
> --enable-real \
> --enable-realrtsp \
> --with-x \
> --enable-snapshot \
> --enable-cyberlink \
> --disable-goom \
> --disable-projectm \
> --disable-osso_screensaver \
> --enable-sqlite \
> --with-kde-solid=no

检查依赖,报了一堆错误.

configure: WARNING: Library libnotify needed for notify was not found
configure: WARNING: Library libraw1394 >= 2.0.1 libdc1394-2 >= 2.1.0 needed for dc1394 was not found
configure: WARNING: Library libraw1394 >= 2.0.1 libavc1394 >= 0.5.3 needed for dv was not found
configure: WARNING: Library gnome-vfs-2.0 needed for gnomevfs was not found
configure: WARNING: Library shout >= 2.1 needed for shout was not found
configure: WARNING: libmodplug not found!
configure: WARNING: Library twolame needed for twolame was not found
configure: WARNING: Library libdca >= 0.0.5 needed for dca was not found
configure: WARNING: Library ogg theora >= 1.0 needed for theora was not found
configure: WARNING: Library dirac >= 0.10.0 needed for dirac was not found
configure: WARNING: Library schroedinger-1.0 >= 1.0.6 needed for schroedinger was not found
configure: WARNING: Library fluidsynth needed for fluidsynth was not found
configure: WARNING: LIBASS library not found
configure: WARNING: The development package for SDL_image is not installed.
You should install it alongside your SDL package.
configure: WARNING: Library librsvg-2.0 >= 2.9.0 needed for svg was not found
configure: WARNING: Not building Roku HD1000 compatible video output
configure: WARNING: Not building Roku HD1000 compatible video output
configure: WARNING: Library portaudio-2.0 needed for portaudio was not found
configure: WARNING: Library jack needed for jack was not found
configure: WARNING: Library libupnp needed for upnp was not found
configure: WARNING: Library libudev >= 142 needed for udev was not found
configure: WARNING: Library libmtp >= 1.0.0 needed for mtp was not found
configure: error: Library sqlite3 >= 3.6.0 needed for sqlite was not found


还是那句话,如果硬盘和网速表示影响不大的话,可以通过 sudo apt-get build-dep vlc 去解决大多数的依赖问题.

不过也有意外情况,因为ubuntu的官方源里面目前还不是最新的1.1.0版本.所以有个别依赖未能满足.

比如:

No package 'xcb-shm' found
>sudo apt-get install libxcb-shm0-dev

No package 'xcb-xv' found
>sudo apt-get install libxcb-xv0-dev

No package 'x11-xcb' found
>sudo apt-get install libx11-xcb-dev


这是vlc 1.1.0 的新特性,用 XCB 取代了之前的 Xlib,这点从vlc 的更新日志里面可以看到.

* Most X11-related plugins now use XCB instead of Xlib. VLC now uses
- xproto,
- xcb, xcb-shm, xcb-xv, xcb-randr (from libxcb),
- xcb-keysyms (from xcb-utils),
- x11-xcb (from libx11) - only for GLX support.


其余的一些也可以在packages.ubuntu.com 里面找到,如 libfluidsynth 等

依赖检查通过后,生成makefile文件,就可以编译了.

执行 make . 这个过程很漫长,耐心等会.

如果期间报错: make[2]: *** [lua/extensions/allocine-fr.luac] 错误 1

应该是 luac 没有安装,不过vlc 是不会报错的……

sudo apt-get install lua5.1 && make distclean

重新编译即可通过.

这次就OK了,完了之后 make install 把vlc安装至指定目录(/usr/local/vlc). 整个过程就算完成了.

运行 vlc --version 查看版本信息.

sharl@sharl-laptop:~/vlc-1.1.0$ vlc --version
VLC media player 1.1.0 The Luggage (revision exported)
VLC 版本 1.1.0 The Luggage (exported)
编译者 sharl 编译时间 sharl-laptop (Jun 27 2010 14:53:29)
编译器: gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5)
本程序在法律许可范围内无任何担保。
您可以依照 GNU 一般公众许可证发布它;
请参阅名为 COPYING 的文件获取详细信息。
由 VideoLAN 小组编写;参见 AUTHORS 文件。
[ 发表评论 ] ( 1223 次浏览 ) 永久链接 ( 3 / 1493 )
编译安装 Cherokee Web Server 1.0.4 通过 

本周cherokee 再次发布新版本,惯例升级。由于1.0.3 为过渡版本,故而忽略。

直接下载安装1.0.4 了.主要修复了一些管理后台的bug.

注:可喜的是,这次镜像列表里面出现了中国服务器(http://cherokee.phpchina.com/),真是不错阿 哈哈.

解压,进入目录

我的configure:
[root@PowerPC cherokee-1.0.4]# ./configure \
> --prefix=/usr/local/cherokee \
> --enable-beta \
> --enable-os-string=Sora_Aoi \
> --enable-trace \
> --enable-backtraces \
> --disable-largefile \
> --disable-ipv6 \
> --enable-internal-pcre \
> --disable-pam \
> --enable-static-module=all \
> --with-libssl=no \
> --with-ldap=no \
> --with-mysql=no \
> --with-geoip=no \
> --with-ffmpeg=no \
> --with-wwwuser=http \
> --with-wwwgroup=web

由于自定义可执行文件路径一直不敢尝试,所以编译过程很顺利~~

接下来,make && make install.

一切OK后,恢复下配置文件 cherokee.conf.

再次启动cherokee,升级完成.
[ 1 评论 ] ( 799 次浏览 ) 永久链接 ( 3 / 1263 )

<< <上一页 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 下一页> >>