编译安装 Audacious 2.4 rc2 通过 

最近看到audacious 官方放出了2.4 分支的第二个候选版本,将是2.x 的第一个稳定分支,而且从2.4 开始默认使用 GTKUI 作为默认界面.这个我很是喜欢.应为很像windows 下的foobar2k,那样的清爽的界面很棒,于是迫不及待的升级。

apt-get purge audacious .卸载掉了我之前安装源里面的2.3 版本.下载源码开始自己编译安装.

下载首页提供的地址,下载 audacious-x.xx.tgz、audacious-plugins-x.xx.tgz 主程序和插件包.解压,进入目录

先编译主程序

我的configure:
[email protected]:~/下载/audacious-2.4-rc2$ ./configure \
> --prefix=/usr/local/audacious \
> --exec-prefix=/usr/local \
> --sysconfdir=/etc/sysconfig \
> --localstatedir=/var \
> --disable-altivec \
> --disable-user-plugin-dir \
> --with-buildstamp=Sharl_MUSIC \
> --with-included-gettext \
> --with-regexlib=gnu

检查依赖,报错,缺少 libmowgli、libmcs 两个库.

执行
sudo apt-get install libmowgli-dev
sudo apt-get install libmcs-dev

问题依旧.libmowgli 还是不满足.要求版本高于 0.7.0. 可是ubuntu源里只有0.6.x.

下载源码自己编译安装,libmowgli项目是audacious 在维护的,主页 http://www.atheme.org/project/mowgli

下载源码包:http://mirror.billymays.us/libmowgli/libmowgli-0.7.1.tgz

解压进入目录:
直接 ./configure && make && make install 即可.

完了后,回到audacious 主程序目录,再次检查依赖,通过.

开始编译.如果 make 出错,错误信息如下的话

gcc: /intl/libintl.a: 没有那个文件或目录
Failed to link audacious2!
make[5]: *** [audacious2] 错误 1
make[4]: *** [all] 错误 1
make[3]: *** [subdirs] 错误 1
make[2]: *** [all] 错误 1
make[1]: *** [subdirs] 错误 1
make: *** [all] 错误 1


看看configure 参数里面是不是有 "--with-included-gettext",删掉即可.audacious 只带了libintl.a.

注:configure string 中最好加上 “--enable-chardet” 以启用字符编码自动识别.不然会乱码.

make 完成后。make install 安装到指定目录.主程序安装成功.

接下来编译插件.进入插件目录

我的configure:
[email protected]:~/下载/audacious-plugins-2.4-rc2$ ./configure \
> --prefix=/usr/local/audacious/plugins \
> --exec-prefix=/usr/local \
> --sysconfdir=/etc/sysconfig \
> --localstatedir=/var \
> --enable-chardet \
> --disable-altivec \
> --disable-mms \
> --disable-bluetooth

检查依赖,报错:
configure: WARNING: *** Cannot find libFLAC, FLACng will not be built ***
configure: WARNING: *** Cannot find WavPack 4.31+, WavPack support will not be built ***
configure: WARNING: Could not find libsamplerate, necessary for jack output plugin.

运行
sudo apt-get install libflac++-dev
sudo apt-get install libsamplerate-dev
sudo apt-get install libwavpack-dev

再次检查,通过.

然后 make && make install. 时间可能会比较长.一切完成后.
audacious 安装成功了.

运行 audcious,出现了主界面,果然,GTKUI 成为了默认界面.
附图一张:

[ ] ( 1412 次浏览 ) 永久链接 ( 3 / 1254 )
编译安装 Pidgin 2.7.3 通过 

今天看到pidgin 官网放出了“Pidgin 2.7.3 is out and contains some important crash fixes” 字样,打算改用新的版本.

在ubuntu packages 里面查了下,pidgin 还是2.6.6 版本,pidgin 官方推荐的PPA(https://launchpad.net/~pidgin-developers/+archive/ppa/+files/pidgin-ppa_0.0.3_all.deb)目前也还只是2.7.1 版本,

故而只好自己动手了,下载最新源码包,解压,进入目录

我的configure:
[email protected]:~/下载/pidgin-2.7.3$ ./configure \
> --prefix=/usr/local/pidgin \
> --exec-prefix=/usr/local \
> --sysconfdir=/etc/sysconfig \
> --localstatedir=/var \
> --enable-static=no \
> --enable-shared=no \
> --disable-largefile \
> --disable-consoleui \
> --disable-screensaver \
> --disable-startup-notification \
> --disable-gstreamer \
> --disable-gstreamer-interfaces \
> --disable-farsight \
> --disable-vv \
> --disable-fortify \
> --enable-gnutls=no \
> --enable-nss=no \
> --enable-trayicon-compat \
> --disable-doxygen \
> --disable-dot \
> --disable-devhelp \
> --with-extraversion=SHARL_LINUX_IM \
> --with-x \
> --with-static-prpls=all \
> --with-python

检查依赖,一切顺利(因为本台机器已经不是第一次编译pidgin了).
紧接着 make && make install 编译 和 安装.

当然之前最好先删除之前老版本的pidgin(如果安装目录一样的话),不然configure 的时候就会有警告了.

编译时间可能会很长,等下即可安装完成.

运行 pidgin 即可,进行添加QQ帐号(如果用户配置文件 ~/.purple 被删的话),添加完成后即可进行聊天了.

切换到“可用”,提示:
您的号码可能存在异常情况,已受到限制登录保护,需激活后才能正常登录。激活网址: http://jihuo.qq.com


看来又要激活了,腾讯什么时候才能完美支持pidgin 呢?? 嚓~

[ ] ( 4181 次浏览 ) 永久链接 ( 3 / 1390 )
编译安装Cherokee 1.0.8 通过 

本周 Cherokee 更新比较频繁,前两天刚刚发布了1.0.7,昨天又紧接着放出了1.0.8,修复一些bug.主要修复的还是SSL/TLS方面的问题,还有个是目录列表的样式bug,囧rz

不管怎样,迅速跟进.下载源码,解压,进入目录

我的configure:
[[email protected] cherokee-1.0.8]# ./configure \
> --prefix=/usr/local/cherokee \
> --sysconfdir=/etc/sysconfig \
> --localstatedir=/var \
> --enable-beta \
> --enable-os-string=Aoi_Sora \
> --enable-trace \
> --enable-backtraces \
> --disable-largefile \
> --disable-ipv6 \
> --enable-internal-pcre \
> --disable-pam \
> --enable-shared=no \
> --enable-static=no \
> --enable-static-module=all \
> --with-libssl=no \
> --with-ldap=no \
> --with-mysql=no \
> --with-geoip=no \
> --with-ffmpeg=no \
> --with-wwwuser=http \
> --with-wwwgroup=web

最近我的vps内存吃得紧,php-fpm 进程也让我减到了10个.由于我的cherokee 基本不与外部程序交互,这次干脆不编译出库了.

检查依赖。没有问题.接下来 make && make install.编译和安装.

一切很顺利.不一会儿就OK了.

然后就是删掉自动生成的配置文件,放入自己的配置文件.再次启动服务器即可.
升级完成.
[ ] ( 1362 次浏览 ) 永久链接 ( 3 / 1352 )
编译安装 Squid Web Proxy 3.2.0.1 通过 

最近squid 也发布了3.2.x 分支的beta版本,较之前的3.1.x 有较大的更新.而我也还在用很早之前编译的3.1.1. 于是决定跟进.

下载源码,解压,进入目录:

我的configure:
[[email protected] squid-3.2.0.1]# ./configure \
> --prefix=/usr/local/squid \
> --exec-prefix=/usr/local \
> --sysconfdir=/etc/sysconfig \
> --localstatedir=/var \
> --enable-icmp \
> --enable-esi \
> --enable-useragent-log \
> --enable-referer-log \
> --enable-kill-parent-hack \
> --enable-cachemgr-hostname=xiazhengxin.tk \
> --enable-cache-digests \
> --disable-http-violations \
> --enable-ipf-transparent \
> --enable-linux-netfilter \
> --enable-follow-x-forwarded-for \
> --disable-ident-lookups \
> --disable-auth-basic \
> --disable-auth-ntlm \
> --disable-auth-negotiate \
> --disable-auth-digest \
> --disable-external-acl-helpers \
> --enable-stacktraces \
> --enable-x-accelerator-vary \
> --enable-zph-qos \
> --disable-ipv6 \
> --with-included-ltdl \
> --with-default-user=cache \
> --with-logdir=/tmp \
> --with-dl \
> --without-libcap

检查依赖,报错
configure: WARNING: cppunit does not appear to be installed. squid does not require this, but code testing with 'make check' will fail.
configure: WARNING: Missing needed capabilities (libcap or libcap2) for TPROXY
configure: WARNING: Linux Transparent Proxy support WILL NOT be enabled
configure: WARNING: Reduced support to Interception Proxy

第一点,基本可以忽略,是c++ 单元测试的一个依赖不足,由于我不需要 make check,故而忽略.

至于 libcap/libcap2 的依赖问题.至今仍未解决.
运行 rpm -qa | grep libcap.
显示 libcap、libcap-devel 均已安装.

而libcap2 则不在yum repo内.

此问题,暂时搁置.

忽略Linux TP功能.进行编译. make && make install.

一段时间后。安装完成.

用之前备份的配置文件覆盖到 /etc/sysconfig 下.最好检查下配置文件,因为squid 3.2.x 移除掉了一些配置参数.具体参看 ReleaseNote.

确认没有问题后,接下来,squid -z 生成缓存. squid 运行缓存服务器.

全部完成.
[ ] ( 970 次浏览 ) 永久链接 ( 3 / 1464 )
编译安装Cherokee Web Server 1.0.7b 通过 

刚刚接到cherokee 邮件列表通知,cherokee 1.0.7 发布了.此版本为bug修复版,主要是修复了管理post请求方面的bug。(这个bug真的是……不知道最近我vps无缘无故重启与这个有没有关系 - -||).

不管怎么样,还是值得更新的.于是乎,下载源码,解压完毕,进入目录

我的configure:
[[email protected] cherokee-1.0.7]# ./configure \
> --prefix=/usr/local/cherokee \
> --sysconfdir=/etc/sysconfig \
> --localstatedir=/var \
> --enable-beta \
> --enable-os-string=Aoi_Sora \
> --enable-trace \
> --enable-backtraces \
> --disable-largefile \
> --disable-ipv6 \
> --enable-internal-pcre \
> --disable-pam \
> --enable-static-module=all \
> --with-libssl=no \
> --with-ldap=no \
> --with-mysql=no \
> --with-geoip=no \
> --with-ffmpeg=no \
> --with-wwwuser=http \
> --with-wwwgroup=web

检查依赖,一切OK。

接下来 make && make install.编译和安装到指定目录(/usr/local/cherokee).
稍等片刻即完成了.

这次我把配置文件安装在了/etc/sysconfig 下,免得以后还要备份的麻烦了.
删除/etc/sysconfig/cherokee 下自动生成的配置文件,放入备份的cherokee.conf.

启动服务器,一切完成.
[ ] ( 2442 次浏览 ) 永久链接 ( 3 / 1282 )

<< <上一页 | 20 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 下一页> >>