编译安装 apache 2.2.14 通过 

最近发现apache.org偷偷摸摸的放出了httpd的最新一个版本 2.2.14,于是迅速跟进.

编译configure 如下:
$ ./configure --prefix=/usr/local/apache/ --enable-v4-mapped --enable-maintainer-mode --enable-isapi --enable-file-cache --enable-cache --enable-disk-cache --enable-mem-cache --enable-echo --enable-charset-lite --enable-mime-magic --enable-usertrack --enable-proxy --enable-proxy-connect --enable-proxy-http --enable-proxy-ajp --enable-proxy-balancer --enable-http --enable-dav --enable-info --enable-cgi --enable-vhost-alias --enable-imagemap --enable-rewrite --enable-so --with-included-apr。

由于我的VPS不支持80之外的所有端口,故没有添加SSL功能. 郁闷呀

在我卸载掉之前的老版本2.2.13 后,我又下载了nginx最新的开发版本0.8.20,安装试跑了一下,本来是打算临时顶替一下apache的,不过试了一下速度,发现蛮快的。

而且体积也相对小巧了不少。一时间还让我产生了干脆抛弃apache的冲动。

不过很遗憾的是,由于nginx并不是原生的支持php,而是要通过fastcgi去中转。当我兴致勃勃的下载了spawn-fcgi的最新版本 1.6.3后,发现我在编译安装php的时候,并没有加入cgi的支持。。。

所以,这个想法只能罢了。继续回到apache怀抱. :)
[ ] ( 3150 次浏览 ) 永久链接 ( 3 / 1666 )
编译安装基于scim的谷歌拼音输入法 

ubuntu系统默认自带的是Scim 输入法平台,里面的什么智能拼音,二笔之类的的确是不太好用.
win下面,我最爱的谷歌输入法。现在好了,linux下面也可以用了.

这个的感谢于scim-googlepinyin项目的作者。
这是项目主页:http://code.google.com/p/scim-googlepinyin/

首先下载源码包:http://github.com/tchaikov/scim-googlepinyin/commits/master/
(一定要是2009-09-04 之后的,不然会出错)

而后解压, 运行 ./autogen.sh。如果报错,这是很正常的.报错信息应该是
checking for pkg-config...
/usr/bin/pkg-config checking pkg-config is at least version 0.9.0... yes
checking for SCIM...
configure: error: Package requirements (scim >= 1.4.0) were not met:
No package 'scim' found


是因为pkg-config找不到 scim.pc文件.

解决方案:sudo apt-get install libscim-dev
而后复制 /usr/lib/scim 下的scim.pc 到 /usr/local/lib/pkg-config (各人系统目录可能不同)
再次生成,通过.

完了之后,出现了 configure 文件.
我的configure: ./configure --prefix=/usr/local/googlepinyin
如果报错,应该是缺依赖.确保已安装以下组件;
* autotools-dev
* libgtk2.0-dev


而后,通过.

最后 make,应该会一次通过.
如果报错,而且是这个错误:
make[2]: Leaving directory `/home/sharljimhtsin/scim/scim-googlepinyin/src'
Making all in data
make[2]: Entering directory `/home/sharljimhtsin/scim/scim-googlepinyin/data'
make[2]: *** No rule to make target `../src/data/dict_pinyin.dat', needed by `all-am'. Stop.
make[2]: Leaving directory `/home/sharljimhtsin/scim/scim-googlepinyin/data'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/sharljimhtsin/scim/scim-googlepinyin'
make: *** [all] Error 2


那么,一定是下载了 2009-09-04 之前的tarball,因为之前的版本有于gcc 4.2.x 和 4.3.x 的不兼容的bug.

换最新版本,make 通过,安装成功.
[ ] ( 3459 次浏览 ) 永久链接 ( 3 / 1626 )
编译安装 gmameui 0.2.11 通过 

最近比较迷恋街机,比如童年时代的 三国战记呀,西游记之类的

看到 gmameui最近发布了最新版本,于是萌发了把模拟器移到linux上的想法,于是下载了源码。

编译安装,

我的configure:
$ ./configure --prefix=/usr/local/mame --disable-doc --disable-scrollkeeper

如果configure 报错的,应该是缺依赖.
确保已经安装好这些组件:
libarchive-dev
libexpat-dev
libgtk2.0-dev
libglade2-dev
libgnome2-dev


如果make出错的话,不出意外的话,应该是
db2omf: Could not construct the OMF subject element.
这个错,因为我也遇到了.

搜索了一下,发现原因是因为旧版本gnome-doc-utils的一个bug.

A bug in older versions of gnome-doc-utils when building with
scrollkeeper disabled.
http://bugzilla.gnome.org/show_bug.cgi?id=427939


既然这个bug是由于自动生成doc引起的,那么这个doc(文档)我们不要也罢.
所以解决方案是在configure 后面跟上 --disable-doc 就ok了.

果然,编译通过.

界面如图;

[ ] ( 4319 次浏览 ) 永久链接 ( 3 / 1609 )
编译安装 apache 2.2.13 通过 

这个apache开源组织也真是的,要么一年没有动静,要么连发了两个版本。

刚出来个2.2.12,又来个2.2.13,本来不想升级,一看changelog,是个bugfix版本。

为了安全,只好跟进。

我的configure:

[[email protected] httpd-2.2.13]# ./configure --prefix=/usr/local/apache2 --enable-v4-mapped --enable-exception-hook --enable-maintainer-mode --enable-modules="all" --enable-isapi --enable-file-cache --enable-cache --enable-disk-cache --enable-mem-cache --enable-bucketeer --enable-echo --enable-example --enable-substitute --enable-charset-lite --enable-logio --enable-mime-magic --enable-expires --enable-usertrack --enable-ident --enable-unique-id --enable-proxy --enable-proxy-connect --enable-proxy-ftp --enable-proxy-http --enable-proxy-ajp --enable-proxy-balancer --enable-ssl --enable-http --enable-dav --enable-info --enable-cgi --enable-cgid --enable-dav-fs --enable-dav-lock --enable-vhost-alias --enable-imagemap --enable-rewrite --enable-so --enable-speling --with-included-apr --with-port=80 --with-sslport=80

编译过程中没有什么困难。至于conf文件,可以把以前的照搬进来,不过最好核对一下。
[ ] ( 1490 次浏览 ) 永久链接 ( 3 / 1670 )
历尽千辛万苦编译安装好 Audacious 

本来就是用audacious听歌的,不过官方源里面的版本(v1.5.1)实在是太低了。

于是就萌发了自己编译的想法,下载了audacious最新稳定版2.1.0 (2009.7.6发布)----程序源码包 和 插件源码包.

本以为应该编译安装很容易,不过我错了。

./configure 到没有什么难度,可选的也不多,很多都是default enable的.

我的 ./configure --prefix=/usr/local/audacious --enable-samplerate

缺依赖就 apt-get install xxx.

make,make install 也很流畅。

不过,audacious-plugins 不太好办

我的 ./configure --prefix=/usr/local/audacious/plugins (很方便,囧rz)

不过刚check了一秒,报错....
Not found Audacious 2.1 or later...

大体意思是找不到主程序的位置.

解决方案:复制 /usr/local/audacious/lib/pkgconfig/下的audacious.pc
到 /usr/local/lib/pkgconfig/下 即可.

继续check..缺依赖 apt-get install.

./configure 通过.

make...又报错..
是进入sid 目录报的错.
audutil.h No such a file or directory...
laudutil 出错
failed to link sid.so

就是 libaudutil挂了.
关于这个问题我搜索了一下,是audacious自身问题(居然说是稳定版 囧rz....)
把libaudutil 合并到 libaudcore中
官网给出了修改的步骤,一共是6个文件.
详见:http://hg.atheme.org/audacious-plugins/rev/5044e5807b67
如果懒得改可以下载修改后的源码包:
http://hg.atheme.org/audacious-plugins/archive/5044e5807b67.tar.bz2

我的解决方案:

把audacious.2.1/src/libaudutil/下的audutil.h 复制
到audacious.2.1/src/audacious/下 即可。

然后make,就没有问题了。
如果报一些 -laudutil 错之类的,找到该文件夹下的 makefile,删掉LIB_PATH 后面 该字符串即可通过.

然后,make check,make install.

安装成功.
[ ] ( 3534 次浏览 ) 永久链接 ( 3 / 1675 )

<< <上一页 | 25 | 26 | 27 | 28 | 29 | 30 | 31 | 32 | 33 | 34 | 下一页> >>