编译安装 Squid Web Proxy 3.2.0.1 通过 

最近squid 也发布了3.2.x 分支的beta版本,较之前的3.1.x 有较大的更新.而我也还在用很早之前编译的3.1.1. 于是决定跟进.

下载源码,解压,进入目录:

我的configure:
[[email protected] squid-3.2.0.1]# ./configure \
> --prefix=/usr/local/squid \
> --exec-prefix=/usr/local \
> --sysconfdir=/etc/sysconfig \
> --localstatedir=/var \
> --enable-icmp \
> --enable-esi \
> --enable-useragent-log \
> --enable-referer-log \
> --enable-kill-parent-hack \
> --enable-cachemgr-hostname=xiazhengxin.tk \
> --enable-cache-digests \
> --disable-http-violations \
> --enable-ipf-transparent \
> --enable-linux-netfilter \
> --enable-follow-x-forwarded-for \
> --disable-ident-lookups \
> --disable-auth-basic \
> --disable-auth-ntlm \
> --disable-auth-negotiate \
> --disable-auth-digest \
> --disable-external-acl-helpers \
> --enable-stacktraces \
> --enable-x-accelerator-vary \
> --enable-zph-qos \
> --disable-ipv6 \
> --with-included-ltdl \
> --with-default-user=cache \
> --with-logdir=/tmp \
> --with-dl \
> --without-libcap

检查依赖,报错
configure: WARNING: cppunit does not appear to be installed. squid does not require this, but code testing with 'make check' will fail.
configure: WARNING: Missing needed capabilities (libcap or libcap2) for TPROXY
configure: WARNING: Linux Transparent Proxy support WILL NOT be enabled
configure: WARNING: Reduced support to Interception Proxy

第一点,基本可以忽略,是c++ 单元测试的一个依赖不足,由于我不需要 make check,故而忽略.

至于 libcap/libcap2 的依赖问题.至今仍未解决.
运行 rpm -qa | grep libcap.
显示 libcap、libcap-devel 均已安装.

而libcap2 则不在yum repo内.

此问题,暂时搁置.

忽略Linux TP功能.进行编译. make && make install.

一段时间后。安装完成.

用之前备份的配置文件覆盖到 /etc/sysconfig 下.最好检查下配置文件,因为squid 3.2.x 移除掉了一些配置参数.具体参看 ReleaseNote.

确认没有问题后,接下来,squid -z 生成缓存. squid 运行缓存服务器.

全部完成.
[ ] ( 1275 次浏览 ) 永久链接 ( 3 / 1813 )

<< <上一页 | 21 | 22 | 23 | 24 | 25 | 26 | 27 | 28 | 29 | 30 | 下一页> >>